Werbung

Wenn SC4 bei einer neueren ATI Karte (speziell die X Serie wie z.B. X800 oder X1600) und Catalyst 6.2 (oder höher) Treibern stark ruckelt, wenn z.B. Gebäude im Bild sind, helfen zwei Tipps, wie oben angeklungen:



Tipp A: Software-Modus statt Hardware-Modus einstellen (leistungsstarke CPU nötig).
Tipp B: Alten Treiber benutzen. Catalyst 6.1 oder niedriger.

Falls "B" keine Lösung ist, weil man neuere Treiber benutzen möchte oder sogar muss, weil die Karte nicht von Cat. 6.1 unterstützt wird hilft evtl
Tipp C:

1. (Standard ATI Treiber) Catalyst Control Center öffnen und unter Grafikhardware die Daten "Grafik-Chipsatz" und "Geräte-ID" notieren. (Beispiel "Radeon X1650 Series" + "71C6")

2. im Installationsverzeichnis von SC4 die Datei "Graphics Rules.sgr" als Backup in ein anderes Verzeichnis kopieren. Dann die Datei im Spieleverzeichnis mit einem Texteditor öffnen und den ATI Abschnitt (im letzten Drittel) suchen.
Dies sieht dann so aus:

# The Radeon series has a very slow path for partial
# depth buffer copies. This has apparently been
# fixed for 9500 and later models in the latest drivers,
# but cannot be fixed on previous Radeons because of
# hardware limitations.
# NOTE: disabling this rule unnecessarily may lead to
# very poor graphics performance.
partialRule "Radeon"
stringMatch cardIdentity "*Radeon*"

partialRule "SlowSubrectDepthCopy" -any
stringMatch cardIdentity "*7?00*"
...


Hier die Daten vom notierten Abschnitt "Grafik-Chipsatz" eintragen, es reicht der Chipsatz mit Sternchen als Platzhalter. Beispiel:

     stringMatch cardIdentity "*X1650*"

3. Die Datei "Video Cards.sgr" als Backup in ein anderes Verzeichnis kopieren. Dann die Datei im Spieleverzeichnis mit einem Texteditor öffnen und den ATI-Abschnitt suchen:

vendor "ATI" 0x1002
card 0x4158 "Mach 32"
card 0x4354 "Mach 64"
...


Dort die gemerkten Daten aus "Geräte-ID" (mit 0x davor!) und "Grafik Chipsatz" eintragen, Beispiel:

card 0x71c6 "Radeon X1650 Series"

(Anmerkung: Schritt 3 scheint nicht unbedingt nötig zu sein, bei mir hat das auch ohne funktioniert. Evtl schon einmal nach Schritt 2 in SC4 testen.)

4. SC4 starten und Hardwaremodus einstellen.
Wenn alles richtig gemacht wurde, lässt SC4 beim scrollen Gegenstände wie Gebäude, Autos, Laternen weg und lädt die nach dem Scrollen wieder nach.
Das Spiel sollte dann wesentlich flüssiger laufen.

(Danke an derfuchsi für die deutsche Fassung dieser Anleitung, auf die Seebaer verwiesen hat und die auf ST von surfheart gepostet und mart_wood einsteigerfreundlicher erklärt wurde.)